Release Notes

Support for Kubernetes versions 1.11.9 and 1.12.7

To address recently announced security vulnerabilities in Kubernetes (CVE-2019-9946 and CVE-2019-1002101), Container Engine for Kubernetes now supports Kubernetes versions 1.11.9 and 1.12.7. Note the following:

  • Container Engine for Kubernetes no longer supports Kubernetes 1.10.x (and earlier) versions.

  • Container Engine for Kubernetes no longer supports Kubernetes 1.11.x versions prior to version 1.11.9  (for example, version 1.11.8 is no longer supported). As a result, you cannot:

    • create new clusters running earlier Kubernetes 1.11.x versions
    • add new node pools to existing clusters running earlier Kubernetes 1.11.x versions

    If you currently have clusters running Kubernetes 1.11.x versions earlier than 1.11.9, Oracle strongly recommends you immediately upgrade those clusters to Kubernetes version 1.11.9  or version 1.12.7.

  • Container Engine for Kubernetes no longer supports Kubernetes 1.12.x versions prior to version 1.12.7  (for example, version 1.12.6 is no longer supported). As a result, you cannot:

    • create new clusters running earlier Kubernetes 1.12.x versions
    • add new node pools to existing clusters running earlier Kubernetes 1.12.x versions

    If you currently have clusters running Kubernetes 1.12.x versions earlier than 1.12.7, Oracle strongly recommends you immediately upgrade those clusters to Kubernetes version 1.12.7.

For more information, see About Upgrading Clusters to Newer Kubernetes Versions.